Back
Maintenance
Maintenance
Upgrade server hardware
Completed 28 Jun at 09:45pm EDT.
evolveme.health
evolveme.health/sso/callback
Completed
Upgrades are complete. Thank you for your patience!
Posted
28 Jun at 09:45pm EDT.
Updated
We are beginning maintenance, please expect services to be unavailable while upgrades are being performed.
Posted
28 Jun at 09:02pm EDT.
Started
As the number of users increased, we noticed that our systems have increased load. We need to perform a more significant upgrade to our hardware that requires some downtime. We anticipate the upgrade to take less than an hour.
Posted
28 Jun at 09:00pm EDT.